
2D.  Installing and Configuring the MPM Office Program 

from a Single Computer to Multiple Computers 

(when other Computer will be Host/Main) 
 

 

Worksheet 

 

The worksheet below has been created to assist your office in installing and configuring 

MPM Office from a single computer on to multiple computers when the original single 

computer is will not be the Host/Main computer.  Written instructions follow over the 

next few pages. 

 

 

Items Needed:  ____ MPM Office Main Setup Executable file 

   ____ MPM Office Upgrade Executable file 

 

 

MPM Office Program Set Up for: _______________________________________ 

      (Provider Name) 

 

Workgroup Name: ________________________________ 
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Instructions 

 

 Remember: We are always here when you need us! 

 

Just because we are teaching you how to do this, does not mean that we expect 

you to do it alone.  You can always count on our friendly and courteous staff to 

assist you with any questions or concerns you may have.   Sometimes it is best to 

have our staff network the MPM Office program to insure that it functions 

correctly. 

 

Please do not hesitate to call us! 

 

 

Before you begin, create a backup of the data previously entered in the MPM Office 

program by following the steps below: 

 

A.  From the Top Navigational Menu, select System → Backup Data, and in the 

opened “Backup MPM Office Data” screen, do the following for each field: 

 

(a) The Archives Folder field shows the path to the file that will contain the 

backup folder.  If set up properly, the Archives Folder field will contain the 

following; “C:\MPM Office\ backup”.  Left click on the browser button ( ) to 

find the “backup” folder within the “MPM Office” folder on your computer. 

 

(b)  The Notes field is a “Free Text” field which allows you to enter something 

that will help you remember what is contained in the backup.  It is 

recommended that you keep this as simple as possible; using just the date and 

time the backup was done as a way to help you remember (see the example 

box below).  

 

 
 

B.   Click the “Backup” button located on the bottom right side of this screen.  The 

following screen will be displayed: 

 

 



 

C.   Finally, a confirmation message will appear stating that the backup was 

successfully saved in the chosen folder. 

 

With the Backup created and your data safe, now you are ready to take the following 

steps to install the MPM Office program on multiple computers when the original single 

computer is not going to host the data: 

 

1.   Choose a computer that will be the Host/Main computer.  This is the one that will 

always be on so long as the other computers need to access the MPM Office data 

files. 

 

2.   On the worksheet, fill in the “Computer Name” field for each computer.  To find the 

Computer Name, find the computer’s Control Panel and then click on the System 

icon.  Find and click on the tab that states Computer Name, and look for the word 

“Full Computer Name”.  Do this for each computer you will be installing the 

MPM Office program on, and proceed to the next step when done. 
 

3.   On the worksheet, fill in the “Workgroup Name” field with name of the workgroup 

found on the Host/Main computer.  All of the other computers must be on this same 

workgroup in order to interact and see each other.  To find the Workgroup Name that 

the computer belongs to, find the computer’s Control Panel and then click on the 

System icon.  Find and click on the tab that states Computer Name, and look for the 

word “Workgroup”.  To verify and/or change a computer’s Workgroup, find the 

computer’s Control Panel and then click on the System icon, and follow the 

instructions given within.  Do this for each computer you will be installing the MPM 

Office program on, and proceed to the next step when done. 
 

4.   Verify that the Windows Firewall is off completely on each computer (as well as any 

Norton, McAfee, or other protection software being used).  This needs to be done to 

allow for each computer to see each other and access each other’s data.  The 

Windows Firewall settings can be found under computer’s Control Panel, clicking 

on the Windows Firewall or Security icon (all other security programs have their 

own settings and you should seek help from the program manufacturer to configure 

their settings).  In order to remain HIPAA Compliant, you should consider having a 

tech professional of your choosing assist you in making the MPM Office program 

work through the Firewall when the Firewall is on, once the MPM Office is installed, 

networked, and running fine on all computers.  Do this for each computer you will be 

installing the MPM Office program on, and proceed to the next step when done. 
 

5.   Verify that both the date and time are correct on each computer (aside from the 

original computer) in order to avoid errors and other possible issues when trying to 

activate the MPM Office program or run reports within the program itself.  To correct 

the date and/or time, find the computer’s Control Panel and then click on the 

Date/Time icon and follow the instructions within.  Do this for each computer you 



will be installing the MPM Office program on, and proceed to the next step when 

done. 
 

6.   Starting from the Host/Main computer, test the Network Interactivity by finding the 

computer’s Control Panel and then clicking in the Network (or Network Places) 

icon, and, if necessary, click on the link “View Workgroup Computers”.  You 

should be able to view all the computers within the network.  Click on their respective 

icons and find and click on their Shared Documents (or Public Documents) folder 

to view, edit, change, and/or delete the contents of any given file within.  Once you 

have verified that you can see each computer that you will be working with (as well 

as tested the interactivity within each one), move on to the next computer and do the 

same.  Do this for each computer you will be installing the MPM Office program 

on, and proceed to the next step when done. 
 

7.   Install the MPM Office Main Setup Executable file that you either downloaded from 

the MPMSoft web site (www.mpmsoft.com), or obtained from the MPM Office CD, 

on each of the computers except the original one that had it installed already.  When 

prompted, confirm the location for installation of the program as “C:\MPM Office”, 

and proceed with the installation following the instructions given in the different 

dialogue boxes within the Software Installation Utility Module.  When the installation 

is done, the installed MPM Office program may open a window asking for a User 

Name and Password.  Click cancel to close.  Proceed to Step 8. 

 

8.   Starting from the Host/Main computer, and including the original computer that had 

the MPM Office already installed on it, install the MPM Office Upgrade Executable 

file that either came with your CD (or one that you may have obtained through an 

email link, or from one of our tech associates).  When prompted, confirm the location 

for installation of the program as “C:\MPM Office”, and proceed with the 

installation following the instructions given in the different dialogue boxes within the 

Software Installation Utility Module.  When the installation is done, the installed 

MPM Office program may open a window asking for User Name and Password.  

Click cancel to close. If more than one MPM Office icon appears on your desktop, 

delete all except the one with the higher value version number (i.e.:  if after the 

upgrade you see MPM Office 4.2 and MPM Office 4.3, delete MPM Office 4.2).  

Proceed to Step 9. 

 

9.   On the Host/Main computer, create the necessary Shared Folders taking the 

following steps: 

(a) Through the Computer icon (or My Computer, or Windows Explorer), find 

and double-click on the MPM Office folder under the “C:\” drive to open its 

contents. 

(b)  From the Top Navigational Menu of the window just opened, select File → 

New → Folder and create two folders:  one labeled “Backup” and the other 

“Electronic Claims” (assuming that they have not already been created by the 

program on installation). 



(c)  Using your mouse with one hand, and using the other to hold down the Control 

(“Ctrl”) key on your keyboard, left-click on the following folders to select 

them:  “Backup”, “Electronic Claims”, “Data”, and “Documents”.  Let go of 

the Control key when done. 

(d)  From the Top Navigational Menu of this window, select Edit → Copy. 

(e)  Through the Computer icon (or My Computer, or Windows Explorer), find 

and double-click on the Shared Documents folder (or Public Documents 

folder) of this computer to open its contents. 

(f)  From the Top Navigational Menu of this window, select Edit → Paste. 

(g)  On each of the pasted folders, right click on the folder name and select 

“Rename” from the menu that appears.  Rename each of the pasted folders as 

follows:  “Backup” becomes “MPM_Backup”, “Electronic Claims” becomes 

“MPM_Electronic_Claims” and “Documents” becomes 

“MPM_Documents”. 

(h)  Close this window when done. 

 

10.   Starting from the Host/Main computer, and for each computer that has the MPM 

Office program installed (except the original one), activate the MPM Office 

program by double-clicking on the MPM Office icon on your desktop and clicking 

on the “Register” button, or if no register button appears, sign in using the word 

“demo” for both the User Name and Password, and from the Top Navigational 

Menu within the MPM Office program, select System → MPM Office Activation.  

In the Serial Number field, enter the number emailed to you (or obtained from one 

of our tech associates), and then click the “Activate” button.  The MPM Office 

program will completely close and reopen asking for a User Name and Password.  

Click cancel to close. Do this on each computer you have installed the MPM 

Office program on, and proceed to the next step when done. 
 

11.   Move back to the Host/Main computer.  Find and double-click on the MPM Office 

icon, sign in using the word “demo” for both the User Name and Password.  Once 

the MPM Office program has opened, link the following areas to their respective 

shared files following the instructions below: 

 

(a)  Linking the Data Folder:  From the Top Navigational Menu, within the MPM 

Office program, select System → Network.  A window labeled “Network” will 

appear, and to the right of the field labeled “Data Folder”, left click on the 

browser button ( ) to open the “Browse for Folder” window.  Find this 

computer’s “Shared Documents” folder (or “Public Documents” folder) 

through Network (or My Network Places), and locate and left click on the 

MPM_Data folder.  Click the “OK” button and then the “Save” button to 

complete this step.  The MPM Office program will completely close and reopen 

asking you to sign in.  Use the word “demo” for both the User Name and 

Password.  Once the MPM Office program has opened, proceed to link the 

next folder. 

 



(b)  Linking the Backup Folder:  From the Top Navigational Menu, within the 

MPM Office program, select System → Backup Data.  A window labeled 

“Backup MPM Office Data” will appear, and to the right of the field labeled 

“Archives Folder”, left click on the browser button ( ) to open the “Browse 

for Folder” window.  Find this computer’s “Shared Documents” folder (or 

“Public Documents” folder) through Network (or My Network Places), and 

locate and left click on the MPM_Backup folder.  Click the “OK” button and 

then to the right of the field labeled “Notes” enter today’s date and time (i.e.: 

041508 244pm) and click on the “Backup” button to create your first backup.  

When the backup is complete, click the “OK” button in the dialogue box that 

opens to complete this step.  Proceed to link the next folder. 

 

(c)  Linking the Documents Folder:  From the Top Navigational Menu, within the 

MPM Office program, select Reports → Document Creator.  A window 

labeled “Document Creator” will appear, and to the right of the field labeled 

“Templates Folder”, left click on the browser button ( ) to open the “Browse 

for Folder” window.  Find this computer’s “Shared Documents” folder (or 

“Public Documents” folder) through Network (or My Network Places), and 

locate and left click on the MPM_Documents folder to expose the 

“Templates” folder.  Click the “Next” button at the bottom right of this 

window, and then the “Close” button immediately thereafter to complete this 

step.   

 

12.   Once all the folders are linked on the Host/Main computer, following the 

instructions in step 11, move on to the next computer.  Follow the instructions 

below to link each folder (the steps are similar to the way it was done for the 

Host/Main computer, but with a few differences).  Continue to do the same for all 

remaining computers, and return to the Host/Main computer when finished: 

 

(a)  Linking the Data Folder:  From the Top Navigational Menu, within the MPM 

Office program, select System → Network.  A window labeled “Network” will 

appear, and to the right of the field labeled “Data Folder”, left click on the 

browser button ( ) to open the “Browse for Folder” window.  Find the 

Host/Main computer’s “Shared Documents” folder (or “Public Documents” 

folder) through Network (or My Network Places), and locate and left click on 

the MPM_Data folder.  Click the “OK” button and then the “Save” button to 

complete this step.  The MPM Office program will completely close and reopen 

asking you to sign in.  Use the word “demo” for both the User Name and 

Password.  Once the MPM Office program has opened, proceed to link the 

next folder. 

 

(b) Linking the Backup Folder:  From the Top Navigational Menu, within the 

MPM Office program, select System → Backup Data.  A window labeled 

“Backup MPM Office Data” will appear.  Verify if the field to the right of the 

label “Archives Folder” displays the new path within it directing the computer 

to the Host/Main computer, or if the field is empty.  If the new path is displayed, 



move to the step below labeled “(c) Linking the Documents Folder”. If the 

field is blank, left click on the browser button ( ) to the right of this field to 

open the “Browse for Folder” window.  Find the Host/Main computer’s 

“Shared Documents” folder (or “Public Documents” folder) through Network 

(or My Network Places), and locate and left click on the MPM_Backup 

folder.  Click the “OK” button and then to the right of the field labeled “Notes” 

enter today’s date, time, and brief message (i.e.: 041508 244pm post linkage) 

and click on the “Backup” button to create your first backup.  When the backup 

is complete, click the “OK” button in the dialogue box that opens to complete 

this step.  Proceed to link the next folder. 

 

(c) Linking the Documents Folder:  From the Top Navigational Menu, within the 

MPM Office program, select Reports → Document Creator.  A window 

labeled “Document Creator” will appear. Verify if the field to the right of the 

label “Templates Folder”, displays the new path within it directing the 

computer to the Host/Main computer, or if the field is empty.  If the new path is 

displayed, return to the Host/Main computer and proceed to step 13.  If the field 

is blank, left click on the browser button ( ) to the right of the field labeled 

“Templates Folder”, open the “Browse for Folder” window.  Find the 

Host/Main computer’s “Shared Documents” folder (or “Public Documents” 

folder) through Network (or My Network Places), and locate and left click on 

the MPM_Documents folder to expose the “Templates” folder.  Click the 

“Next” button and then the “Close” button immediately thereafter to complete 

this step.   

 

13.    Once the Shared Folders have been linked, the database will need to be Restored 

from the Backup File created at the very beginning.  Move back to the original 

computer that the backup was created on and take the following steps:   

 

(a) Through the Computer icon (or My Computer, or Windows Explorer), find 

and double-click on the Backup folder within the MPM Office folder under the 

“C:\” drive to open its contents. 

(b)  Find the backup file containing the most recent date and time, and right click on 

it.  From the menu that appears, left click once on the option “Copy”. 

(c)  Through the Computer icon (or My Computer, or Windows Explorer), find 

and double-click on the Shared Documents folder (or Public Documents 

folder) of the Host/Main computer and locate within it the MPM_Backup 

folder.  Double click on this folder to open its contents. 

(f)  From the Top Navigational Menu of this window, select Edit → Paste to drop 

the copy of the backup created from the original folder into this folder. 

(g)  Once the previous backup has been placed in this folder, close this window and 

return to the Host/Main computer. 

(h)  Make sure that all other computers that have the MPM Office program installed 

on them, have the program itself completely closed. 



(i)  On the Host/Main computer, proceed to open the MPM Office program by 

double clicking on the MPM Office logo on the computer desktop, and using   

the word “demo” for both the User Name and Password.  

(j)  From the opened MPM Office program, from the Top Navigational Menu, 

select System → Restore Archive.  From the opened “Restore Archive” 

window that opens, left click on the browser button ( ) to the right of the field 

labeled “Archives Folder”, open the “Browse for Folder” window.  Find this 

computer’s “Shared Documents” folder (or “Public Documents” folder) 

through Network (or My Network Places), and locate and left click on the 

MPM_Backup folder.  From the list that appears, select the Archive File 

which contains the Notes that match the date and time of the backup made on 

the original computer which you will have the MPM office program to revert to. 

(k)  Left-click on the Archive File name and then click on the “Restore” button at 

the bottom right hand side of the screen.  Click “Yes” in the “Restore MPM 

Office” box that has just opened.  Click “Yes” again when it asks you a second 

time to confirm.  You will be given another chance to make sure this is the 

correct file before the program is actually restored.  The program will then 

restore and reindex the data, and will shut down completely and then reopen. 

 

14.    On the Host/Main computer, sign in to the MPM Office program again using the 

word “demo” for both the User Name and Password.  Once the MPM Office 

program has opened, test the Interactivity of the MPM Office Program by 

performing the following steps on each computer: 

 

(a)  From the Top Navigational Menu select To Do’s → Add New Task. 

(b)  From the opened “Add New Task” box, left click in the box to the right of the 

word “Priority”.  Then, in the field to the right of the word “Task” enter “Test 

from Computer Name” (whereby Computer Name is the name of the computer 

you are currently on), and click “Save” to close this box. 

(c) From the Top Navigational Menu, select File → Exit to close completely out of 

the MPM Office program. 

(d)  Move on to the next computer and do steps (a) – (c) again for each remaining 

one. 

 

If the preceding 13 installation and configuration steps have worked well, 

when you open the MPM Office on each of the remaining computers, you 

well see the note entered from the previous computer.  This action confirms 

the fact that the computers are correctly Networked and interacting with each 

other (being able to add and save information to the Host/Main computer).  
 

(e)  Return to the Host/Main computer and upon opening the MPM Office program, 

left click on each of the entries that appear in the box labeled “Important 

Task” and proceed to delete them by clicking on the “Delete” button at the 

bottom of this box until they have all been deleted.  When done, close this box 

by clicking on the “x” on the top far right of this box to complete this step. 

 



 

Congratulations! 

 

The MPM Office program is now successfully installed on each of your networked 

computers.  You have one last step before beginning to use this program and that is to 

Print the User Manual.  

 

With the MPM Office program opened, select Help → Help from the Top Navigational 

Menu.  The User Manual is actually a step-by-step Setup and User Guide taking you from 

zero to hero in 26 easy to read and easy to follow instructional pages.  It is a PDF file and 

you need to have the free Adobe Reader installed on your computer to read it.  You can 

download the free Adobe Reader from www.adobe.com. 

 

 

FYI 

 

Sometimes, though, although you have done everything correctly, you may receive an 

error when trying to access the program.  This is not due to the program itself, but rather 

due to user error, operating system limitations (based on the type of Windows 

operating system being used), or connectivity issues that arise within the established 

wired or wireless network. 

 

 

When attempting to open 

MPM Office from a 

computer other than the 

Host/Main computer, you 

may receive the following 

error:  (the computer 

address shown here is a 

sample only)  

 

This error is due to the fact that the computer you are using is unable to connect to the 

Host/Main computer where the data file being shared is kept.  Depending on how many 

users there are, solutions may vary.  See below: 

 

 

FOR WORK GROUPS WITH LESS THAN 9 USERS 
 

There are four main possible reasons for this: 

 

(a)  The Host/Main computer is not turned on. 

(b)  The Host/Main computer is restricting the sharing of the data folder due the 

computer’s firewall blocking the access into it, or due to the permissions not 

being set up correctly for the shared folder.  (You may need to contact a local 



tech service company or your local computer store that offers on-site network 

set up for assistance). 

(c)  The entire network may be down, or the network connection from the 

Host/Main computer to the router (or from the computer you are using to the 

router) may be down.  (You may need to contact a local tech service company 

or your local computer store that offers on-site network set up for assistance). 

(d) The wireless connection from the computer you are using to the router to the 

Host/Main computer may be taking a long time and the system has timed out.   

(You may need to contact a local tech service company or your local computer 

store that offers on-site network set up for assistance).    

 

Keeping each computer fitted with the highest amount of RAM (Random Access 

Memory) that it is made for, and making sure each computer also has a high speed 

processor, will help in getting the connections to happen quicker and allow for everyone 

to be able to access the data without interruption. 

 

  

FOR WORK GROUPS WITH 10 OR MORE USERS 
 

Aside from the 4 main reasons listed above, you may want to consider the following:  the 

use of a dedicated server - a computer designated to handle more than enough users at 

one time.  This, along with keeping each computer fitted with the highest amount of 

RAM (Random Access Memory) that it is made for, and making sure each computer also 

has a high speed processor, will help in getting the connections to happen quicker and 

allow for everyone to be able to access the data without interruption. 

 

In situations where no server is available, the MPM Office program will be using the 

networking features of the Windows operating system to be able to find and share data 

located on another computer.  Windows calls this Peer to Peer File Sharing, 

and Windows allows up to 10 different users to be able to access a shared folder 

simultaneously. 

 

The Host/Main computer (holding the shared file) issues up to a maximum of 10 

authentication tokens at one time.  If for whatever reason all 10 tokens have been taken, 

the Host/Main computer kicks out the other computers that are trying to access the shared 

file. 

 

This situation is similar to when you make reservations at a hotel - the room you reserved 

is yours until a certain time of day before it can be released to someone else.  If you do 

not show up by that appointed time, your room is given to someone else, but not until that 

time comes and goes can your room be given away.  So even if you don't show up, 

someone else can't get that room until the room is released. 

  

If someone opens and then closes their MPM Office program on their individual 

computer, the Host/Main computer that issued their authentication token has reserved that 

token for that computer only and for a specific time period that it alone knows and 



designates (a technology expert versed in Windows Peer-to-Peer Networking would 

possibly be able to advise you as to what this time period is).  So, even if that person no 

longer wants to use the MPM Office program anymore during that allotted time period, 

that computer’s token will not be released for someone else to use, and it is not 

transferable (meaning I can’t just give my token to someone else to use).  In this case, the 

only resolution is to have another user access the program from one that was already 

previously accessing it.  

  

Unfortunately, this is a Windows limitation and not an MPM Office program issue. 

 

If your specific issue was not answered with the information provided above, please call 

our tech support department during normal business hours so that we can provide 

assistance.    We may need to ask that you consult with a local tech service company or 

your local computer store that offers on-site network set up for further assistance if the 

problem is truly a non-MPM Office related issues. 

 

 

 

FREQUENTLY ASKED QUESTIONS 

Q1:  Our networked computers randomly go down.  Is there something that can be done 

about that?  It gets caught in a "please wait" syndrome and won’t do anything 

unless we shut down and restart. 

A1:  This is not an MPM Office issue; it is an issue of your computer(s).  Have a 

computer tech person in your area check to see that (a) you have more than 1.5 MB 

of RAM on each computer, (b) that they have at least 1.5 GHZ processor speed, and 

(c) that they are networked correctly and nothing is blocking or interfering with the 

transmission between the computers and the host computer which holds the data. 

 


